[texhax] pstricks problem

Zbigniew Nitecki zbigniew.nitecki at tufts.edu
Thu Jan 10 16:58:08 CET 2008

I cannot understand the following problem, unless some style file has  
been corrupted.

Recently, to correct a problem caused by a typo in babel's latin.ldf  
file on TeXlive, I replaced that file with an updated one from CTAN  
(making no other changes).  Since then, whenever I tex a file whose  
package calls to pstricks are
\usepackage{pstricks, pst-plot,pst-math,pst-3dplot}
%\usepackage{pstcol, %%obsolete?
%\usepackage{pst-char, %%obsolete?
I get a string of error messages of the following sort:
! Package xkeyval Error: `linewidth=1pt' undefined in families  

See the xkeyval package documentation for explanation.
Type  H <return>  for immediate help.

l.142 ...line[linewidth=1pt, linestyle=dashed]{->}
(various standard pstricks parameters get this treatment).
When I go into silent mode and simply ignore the warnings, the  
pictures come out fine.

Now, when I tex another file, whose calls to pstricks are just the  
first \usepackage above,
I get no error messages.

I am using TeXShop, with latex+ghostscript, using the latest  
distributions from TeXShop, which I believe are those on TeXLive.

Any ideas about what to do?

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155

Office    (617)627-3843
Dept.    (617)627-3234
Dept. fax    (617)627-3966

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/texhax/attachments/20080110/dc59a997/attachment.html 

More information about the texhax mailing list