[tex-live] Debian TeX -- new packages
sanjoy at mrao.cam.ac.uk
Tue Mar 27 14:55:10 CEST 2007
> We ask people using Debian to try these packages out, they survived
> all my tests and quite a lot of documents I tried out, but YMMV.
[What I describe below is not a Debian problem, but the proposed
change would make the packages easier for Ubuntu users to use.
I added dev-context to the CC: list since the pkg deps affect Ubuntu
users -- e.g. me -- who use your excellent ConTeXt packages.]
I'm using Ubuntu 6.10 (edgy) with all your tug.org stanzas. An
"apt-get install texlive-base-bin" or "apt-get install context" fails
when going from the TL2005 packages to the 2007 ones. The blocking
package is texlive-base-bin:
# apt-get install texlive-base-bin
Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-5.1ubuntu0.1 is to be installed
Depends: libpoppler0c2 (>= 0.4.2) but it is not installable
E: Broken packages
I'll upgrade to the Ubuntu 7.04 beta, which will solve the libpng12-0
problem because Ubuntu 7.04 uses libpng 1.2.15. But libpoppler0c2
would still be missing. Here are the libpoppler pkgs in versions of
5.04 (hoary) | libpoppler0-0.1.2
5.10 (breezy) | libpoppler0c2-0.4.2
6.04 (dapper) | libpoppler1-0.5.1
6.10 (edgy) | libpoppler1-0.5.4
7.04 (feisty) | libpoppler1-0.5.4
So, could you add libpoppler1 as an alternative libpoppler dependency?
That should fix the installation. libpoppler1 is also in Debian (in
experimental) so it should be a useful Debian change eventually.
Then I can update to texlive 2007 and to the latest ConTeXt via
apt-get. If that works, I'll update the ConTeXt wiki's installation
instructions to say that Ubuntu users will have to upgrade to 7.04 to
use your latest packages.
Although, if it's possible to depend on an older libpng (on
libpng12-0-1.2.8), then more Ubuntu users could upgrade.
`Not all those who wander are lost.' (J.R.R. Tolkien)
More information about the tex-live