[Fontinst] ITC Galliard CC - ff, ffi & ffl ligatures

Christopher Adams chris at raysend.com
Tue Apr 28 13:50:41 CEST 2009

> Can you please do t1testpage on the fonts and place the ps files online.

I installed t1testpage and ran it over GalliardAltCC-Roman {fglra8a}. I've
placed the results here:


You can see the fj ligature sitting in slot j. ff, fi, fl, ffi & ffl are in
slots V, W, X, Y & Z.

I also ran this over the Roman and OSF fonts, but the resulting .ps file
only seems to contain the last 118 glyphs. (from emdash to zcaron) Why is


I have been able to insert the ff, ffi & ffl ligatures into the Roman by
following Dr. Rees's advice and using reglyphfonts. The relevant portions of
my fontinst script are as follows:

\transformfont{fglr8r}{\reencodefont{8r}{\fromafm{fglr8a}}} %Roman
\transformfont{fglri8r}{\reencodefont{8r}{\fromafm{fglri8a}}} %Italic
\transformfont{fglra8r}{\reencodefont{8r}{\fromafm{fglra8a}}} % Alt Roman
\transformfont{fglria8r}{\reencodefont{8r}{\fromafm{fglria8a}}} % Alt Italic

    \renameglyph{fj}{j} % Useless for now, because t1.etx has no slot for

%these instructions use t1fgl.etx, which for now is an exact copy of t1.etx
\installfont{fglrc8t}{fglrc8r,fglr8r suffix

\installfont{fglr8c}{fglr8r,fglrc8r suffix
\installfont{fglri8c}{fglri8r,fglrij8r suffix

[...] % removed install commands for {fglj}


Now, about the fj ligature...

I tried editing t1fgl.etx and adding a slot for the fj ligature. As a base
case I simply switched all instances of {FI}{fi} with {FJ}{fj}, and sure
enough the fj ligature appeared for all instances of fi in my test file.

I then tried removing one of the slots (dotlessj, I believe) and setting a
new slot for fj, following the syntax for the other f ligatures, and while
my testfile compiled all the glyphs seemed to be shifted over, so the wrong
glyphs were being placed. I then tried changing the above to use OT1, but
got an error about missing {fgl} font.

For the fj ligature, you have to iclude it in the 8r.enc vector.

I'm afraid I don't understand what this means.

>  If you don't have t1testpage but
> ghostscript and shell, you can do this in the fonts directory:
> gs -dBATCH -dNOPAUSE -sDEVICE=pswrite  -sFONTPATH=.  -sOutputFile=
> galliard.ps   prfont.ps -c `grep FontName *afm | sed 's/^FontName
> \(.*\)$/\/\1 DoFont/'`

Is the only part of this that needs to be replaced the FontName? What name
do I use? The file name, or the name acording to what is stated in the afm
file? I tried a few different settings, but the output was a blank page.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/fontinst/attachments/20090428/52abead7/attachment.html 

More information about the fontinst mailing list