[Fontinst] error that I don't understand

Lars Hellström Lars.Hellstrom at math.umu.se
Sat Jul 31 16:18:11 CEST 2004

At 11.59 +0200 04-07-31, E. Saudrais wrote:
>Hi fontinst users,
>I used a french distribution (AsTeX) that uses emtex. I have no problem
>using fontinst.
>This summer, I installed miktex (both distributions run without any
>problem on my PC), but I got an error runing fontinst.
>Let see en example with a simple font (amigo) --- see tex file below.
>-> No problem if I run latex with astex.
>-> If I run latex with miktex, I get a lot of lines like
>! Missing number, treated as zero.
><to be read again>
>                    \i-rawscale
>\setscaledrawglyph ...en \e_count =\int {rawscale}
>                                                   \multiply \a_count
>l.24 ...ace}{pair8r}{10pt}{1000}{32}{251}{0}{0}{0}

This could be a bug with \if_defined that one encounters if running
fontinst v1.926 (possibly also some earlier versions) on e-TeX. Check which
executable is being used in the miktex case, and try to use another (e.g.

>Source file:

It's not necessary to format the command file as a LaTeX document. The
above could just as well have been

  \input fontinst.sty


And a simple \bye would do instead of \end{document}.

Lars Hellström

More information about the fontinst mailing list