philosophy and Adobe Garamond

Lars Hellström
Sat, 17 Jul 1999 09:25:57 -0400

Will Adams wrote:
>Sorry, failed to touch upon the philosophy aspect in my previous missive, but
>found and used the .vf files and my query/point was made moot thereby.
>Thierry Bouche's Agaramond set sort-of, kind-of worked, but no ff ligatures
>(I do have the expert sets) and no regular weight small caps or old-style
>figures (maybe this is why no ff-ligatures?). Not sure what the difficulty
>was and rather than pursue that, I tried installing AGaramond with FontInst
>proper. No joy.
>I have FontInst placed in h:\localtexmf\generic\fontinst and after renaming
>the .afms here're the messages which I got in the padfi.log file which
>padfi.tex (shown below) generated.
>\input fontinst.sty
>This is TeX, Version 3.14159 (MiKTeX 1.20b) (preloaded format=plain 1999.7.5)
> 11 JUL 1999 21:10
>(padfi.tex (fontinst.sty
>No file fontinst.rc.
>INFO> parse family <pad><> (expert)
>INFO> to make LaTeX font shape <padx,m,n,> seek padr8r.mtx
>INFO> run \transformfont  <padr8r> from <padr8a>
>Metrics written on padr8a.mtx.
>Raw font written on
>! I can't find file `8r.etx'.

This is what causes at least the first of your errors: TeX simply cannot
find the file 8r.etx. (On CTAN, this file is located in the
.../fontinst/inputs/etx directory.) I suspect that you get this error
because the directory in which you have placed 8r.etx is missing from your
TeX's search path of input directories, but it could also be that you
haven't downloaded all the input files fontinst needs (the complete set of
files consists of what can be found in the .../fontinst/inputs subtree on

As for the other errors you get, they seem to either be caused by the first
one or stem from the same root as that, i.e., your TeX cannot find the
files fontinst wants to input. I noticed for example that it said

>! I can't find file `latin.mtx'.

a bit further down. latin.mtx is also one of the files fontinst needs, and
in this case it is found in the .../fontinst/inputs/mtx directory on CTAN.

>I'm wondering if the difficulty might not be that I have a _very_ old version
>of AGaramond.

No, that isn't the source of this error, and it shouldn't matter much
either, since once a font has been "cut" there is absolutely no reason to
change it and lots of reasons not to. Fonts are propably the most
unchanging type of software there is today.

Lars Hellström